Service disruption in EU

Incident Report for Flatfile

Resolved

A fix has
Posted Oct 23, 2025 - 03:51 PDT

Identified

We have identified the issue and are rolling out a fix
Posted Oct 23, 2025 - 03:22 PDT

Investigating

We are currently investigating reports of a service degredation on our EU platform region
Posted Oct 23, 2025 - 03:13 PDT
This incident affected: EU Regional Platform (EU Platform API, EU Spaces).